A4000: Kei up and running OS3.1

A4000-MBThis is a busy week on the Amiga side of things, A4000:Kei is now up and running.

I got this MB as part of a bulk sale of items from someone who was slimming down their collection. It came with a non standard card riser, floppy drive and OS3.1 install disks.

A little while ago, I decided to start cleaning out the collection — items that work or can get working were going to be kept and the rest would be sent out onto Ebay. Getting this machine working was a little bit painful, as there was no PSU and the board had seen better days.

Making an PSU was fun, but getting the MB connector was a pain. I am used to working with A2000/500’s and never owned a A3000/4000 type machine. It would have been a shame if I had to let this one go :). Making a PSU that was compatible required butchering of an old power supply, but after all the work I noticed it didn’t have a power switch. Arg. A little hack job from a dead PSU and everything was good.

Once the power was working and verified, the black screen after all that work was really disappointing. Re-seating everything didn’t help. Spent an hour cleaning everything, contacts and the processor card. I think there is maybe two socketed chips (excluding the KS) on the whole board — not like previous Commodore gear I have worked on over the years.

After the cleanup I noticed I was missing a few jumpers, added them from a dead MB in the basement. Went back to reading about A4000’s and their issues. The original battery was there, and looked like it had some leakage, but nothing that bad (will have to deal with that soon..). After moving cables around one of the PSU cables fell on the processor card and suddenly the KS screen popped up. I took a look inside the processor card and there was a toothpick in the slot, laying flat at the bottom. A little upside down shake and it dropped out. A push of the processor card into place and the KS screen appeared. That was a first.

A4000-INSTThe floppy drive booted the OS3.1 Install disk without issue. It was amazing to see that go. I was surprised that the disks actually worked. Most of my original Amiga disks are questionable at best.

Bitching about SCSI issues over the years, I thought that going to a simple IDE interface was going to be the least of my problems. I have crates of old IDE drives, most of them are 10GB and above. There are reams of IDE cables in a bin. Brought up stack of everything, set the drives to master and went crazy for a few hours. Nothing would work. Black screen, sat there for minutes still no boot from floppy. Unhook the drive, the floppy would boot after a period of time. Swapped out cables, drives and combinations of configurations. Mounted the drives on a PC to verify them. Maybe they were not that compatible, with the IDE in the Amiga.

Back to the basement, more drives must be here somewhere.. maybe something smaller? Ohh, theres a box of DVD/CDROM’s. I’ll grab one of those for later. After a few more hours of waiting for a drive to boot, I went for a walk with a friend. Came back, wondered what would happen if I hooked only a CDROM up. That did it, the system booted to floppy right away, no wait. Weird.

Installing a CDROM at the end of the chain (set to slave), with HD in the second slot (set as Master) allowed the system to boot. HD by itself, no. With the CD, yes.

A4000-OS31Being spoiled by Windows/Apple Partitioning systems over the years — going back to the Amiga partitioning software gave me the old feeling of — I can really screw this drive up. I recalled some of the drive size requirements for various versions of the OS. So the first drive I made 500 MB and then a second partition that was 2 GB. Looking at the space left, the max visible from this OS was ~4 GB. I’ll have to sort that out later, to get the additional space back.

I was pretty amazed with the OS3.1 installer. It actually worked and was painless.

 

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.