Acer X34P: Learning about DP / 120 Overdrive and Black Flicker

I bought one; Acer’s X34P. There are people that love them and others that have RMA’d them multiple times.

There are a few caveats; not only does mine work (not right away either) but its in a KVM config which really should be the kiss of death for this to work correctly.

Initially, the display was connected via DP to a KVM (GCS1934), to 4 machines (Win10/Nvidia670M, Win10/Nvidia980ti, Win10/Nvidia1060 and MacOSX). All of these connect at 60hz. All of these display full screen native resolution.

On the 980ti machine, I ramped the display up to 100hz and random intervals I’d get the DP port resetting (brief blackout screen and DP in the upper right corner). It was annoying. Running the overclock made it worse @ 120hz. Games or desktop. A lot of config fiddling led to slightly better results but still flickering. I turned off the audio (which was my plan from the start as I dislike monitor sound).

A lot of reading later, I unplugged the KVM from the mix. Surprise — worked. I need that KVM. So I pulled the segment of DP cables that that particular machine was using. I had the heavy duty (well made) and worked in my non KVM test as the monitor. This cable was really long. I had a few 3 footers that were decent quality. Once I made the run smaller, the KVM and the display worked at 120hz.

There are a lot of thoughts about cable quality — but sometimes length throws things out of whack. I tested this with 10 cables. Only the short ones (except for one) worked.

Now that it works with everything — I love this monitor. First thing I am doing is replacing the base stand with a desk arm.. man those feet are huge.